# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<user>.*?)\s*\((?P<hhmm>(?:\d|[01]\d|2[0-3]):[0-5]\d)\):\s*(?P<Quote>.*(?:\n(?!\n).*)*)"
test_str = ("Peter (08:16): \n"
"Hi \n"
"What's up? \n"
";-D\n\n"
"Anji Juo (09:13): \n"
"Hey, I'm using WhatsApp!\n\n"
"Peter (11:17):\n"
"Could you please tell me where is the feedback?\n\n"
"Anji Juo (19:13): \n"
"I don't know where it is. \n\n"
"Anji Juo (19:14): \n"
"Do you by any chance know where I can catch a taxi ?\n"
"🙏🙏🙏\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.