$re = '/(\.\d{6})(\d{3})/m';
$str = '03-MAY-22 02.42.33.000000000 AM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);