package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Writer : (?P<Writer>[\s\S]+?)Director : (?P<Director>[\s\S]+?)Producer : (?P<Producer>[\s\S]+)`)
var str = `Writer : Jeffrey Schenck / Peter Sullivan / Director : Brian Trenchard-Smith / jack / Producer : smith`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}