using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:ECO-(?!DE)[^\s]+)(?: (?:RX|B|N|M|UP|UP B|UP N|UP M))?)\s+(.*?)(?=(?:ECO-(?!DE))|\z)";
string input = @"NOVEDADES ULTIMAS UDSSIN STOCK POCO STOCK CLIMATIZACIÓN - PURIFICACION REF. ESTADO DESCRIPCIÓN FECHA OBSERVACIONES ECO-698 Acondicionador Frio-Calor ECO-CHI-522 Chimenea eléctrica con patas ECO-CHI-530 Calefactor purificador ECO-3005 Halógeno Oscilante 400-800-1200 Watts DESCATALOGADO ECO-3100 Purificador Mural con luz UV y depósito ULTIMAS UDS ECO-3180 Ozonator Plus - Purificador de aire y agua ECO-352 Frego Mopa Vapor ECO-354 Aspirador Blower Wet&Dry ECO-356 Aspirador Cyclon ECO-358 Aspirador limpiacristales ECO-998 Robot Aspirador Absolut Carbon ECO-998 RX Robot Aspirador Absolut Carbon - Recambios ECO-3150 AQUA FILTER TOWER ECO-3150R FILTROS AQUA FILTER COCINA - HOGAR REF. ESTADO DESCRIPCIÓN FECHA OBSERVACIONES ECO-032 Sartenes Granite Stone, 6 pcs ECO-018 Cuchillos cerámicos ECO-DE ECO-012/8 Magic Tupper 8 pcs ECO-050 Bolsa Isotérmica Portaalimentos Deluxe ECO-052 Bolsa Isotérmica Portaalimentos Cuattro ECO-054 Bolsa Isotérmica Portaalimentos Burber ECO-056 Bolsa Isotérmica Portaalimentos Fashion ECO-058 Bolsa Isotérmica Portaalimentos Flower ECO-062 Bolsa Isotérmica Portaalimentos Summer ECO-060 Bolsa Isotérmica Portaalimentos Spring ECO-398 Batidora / Licuadora DIETA MIX ECO-400 Robot de cocina DietaChef ECO-C-3500 Cubeta extra ""Luxury Chef"" ECO-DE MASAJE REF. ESTADO DESCRIPCIÓN FECHA OBSERVACIONES ECO-310 Masajeador de pechos ECO-DE ECO-314 Gafas de masaje ECO-4005 SAUNA FACIAL ECO-DE ECO-920 Colchoneta de masaje Vibración + Calor ECO-725 Respaldo de Masaje ECO-DE ECO-4000 Masajeador Vidafir ECO-4020 Masajeador Vidafir PRO ECO-4012 Masajeadore de pies con Presoterapia Shiatsu ECO-4002 Cojín de masaje con infrarrojos ECO-4050 Cojín de masaje Vidalife ENTRADA INMEDIATA ECOGEST TRADE S.L. STOCKS ALMACEN ESTADOS 17/05/2019 ECO-4004 Masajeador de cuello Cervical Vibroneck ECO-4006 Masajeador de cuello ECO-4100 Cinturon de masaje Vibrofir ECO-4160 Cinturon de masaje ECO-739B Sillon de masaje con puff beige ECO-739N Sillon de masaje con puff negro ECO-8550 UP M Sillon de masaje Levantapersonas Milano Marrón DESCATALOGADO ECO-8550 UP N Sillon de masaje Levantapersonas Milano Negro DESCATALOGADO ECO-8196 N Sillón de masaje ""Confort"" NegroULTIMAS UDS ECO-8196 UP B Sillón de masaje levantapersonas ""Confort plus"" Beige ECO-8196 UP M Sillón de masaje levantapersonas ""Confort plus"" Marron 11-jun ECO-8196 UP N Sillón de masaje levantapersonas ""Confort plus"" Negro ECO-8500 Sillon de masaje Imperial en tela marrón ECO-8615 M Sillón de masaje balancín en PIEL color marrón ECO-8615 N Sillon de masaje balancín en PIEL color negro ECO-8620 UP Sillon de masaje elevador en piel ECO-8198 B Sillon Maximum Beige ECO-8198 M Sillon Maximum Marrón ECO-8198 N Sillón Maximum Negro ECO-8198 UP B Sillón Máximum levantapersonas Beige ECO-8198 UP M Sillón Máximum levantapersonas Marrón ECO-8198 UP N Sillón Máximum levantapersonas Negro ECO-8200-2 B Sofá Vibroluxe Beige 2 pl 30-may ECO-8200-2 M Sofá Vibroluxe Marrón 2 pl ECO-8200-2 N Sofá Vibroluxe Negro 2 pl ECO-8200-3 B Sofá Vibroluxe Beige 3 pl 30-may ECO-8200-3 M Sofá Vibroluxe Marrón 3 pl ECO-8200-3 N Sofá Vibroluxe Negro 3pl ECO-8220 B Sofa Cama con masaje + Ottoman Bellagio Beige ECO-8220 N Sofa Cama con masaje + Ottoman Bellagio negro ECO-8630 B Sillon de masaje elevador Shiatsu Beige DESCATALOGADO ECO-8630 N Sillón de masaje elevador Shiatsu Negro ECO-762 N Sillon de masaje alta gama Berlín ECO-118B Silla de oficina ULTIMAS UDS ECO-120B Silla de oficina color blanco DESCATALOGADO ECO-122B Silla de oficina color blanco ECO-122N Silla de oficina color negro ECO-124 Silla de oficina color negro ECO-126 Silla de oficina color Beige SIN FECHA ULTIMAS UDS ECO-150 Silla de oficina con masaje, color negro FITNESS REF. ESTADO DESCRIPCIÓN FECHA OBSERVACIONES ECO-304 ELECTROESTIMULADOR MINI TENSE ECO-306 ELECTROESTIMULADOR EMS 17/05/2019 ECO-308 ELECTROESTIMULADOR TENSE ECO-800 MINI BIKE ECO-DE ECO-802 Bicicleta eléctrica Happy Hands and Legs ECO-808 Biicleta X Top25-jun ECO-811 Bicicleta magnetica ""MAGNET BIKE"" ECO-812 Bicicleta Spinning ""Giro Pro"" ECO-815 Bicicleta Spinning ""Evolution Tour"" ECO-818 Bicicleta de Spinning ""Racer Pro"" ECO-819 Bicicleta de Spinning ""Trainer Pro"" ECO-820 Bicicleta de Spinning ""Panther"" ECO-826 Bicicleta de Spinning Shark ECO-827 Bicicleta de spinning Absolut ECO-828 Bicicleta de Spinning ""indoor"" ECO-508 Plataforma Oscilante Platinium Step ECO-514 Plataforma Body Plate 3000 ECO-846 Tabla de inversión ECO-848 Tabla de inversión luxury ECO-2570 Cinta de andar ECO-2580 Cinta de andar ECO-2590 Cinta de andar ECO-2595 Cinta de correr LCD, Mp3 y masaje ECO-850 Banco de ejercicios ECO-HG029 Banco de ejercicios ECO-849 Banco multiejercicios compacto ECO-851 ABDOMINAL TRAINER ECO-4060 VIDASTEP ECO-550 3D Total Gym ECO-DE ULTIMAS UDS DESCANSO REF. ESTADO DESCRIPCIÓN FECHA OBSERVACIONES ALMOHADAS DISPONIBLES EN TODAS LAS MEDIDAS COLCHONES - MEDIDAS ESPECIALES CONSULTAR PLAZO 17/05/2019";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}