#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)('template_path_stack' => )(\[((?>[^\[\]]++|(?2))*)\])"
Local $sString = "<?php" & @CRLF & _
"" & @CRLF & _
"namespace Application;" & @CRLF & _
"" & @CRLF & _
"use Laminas\Router\Http\Literal;" & @CRLF & _
"use Laminas\Router\Http\Segment;" & @CRLF & _
"use Laminas\ServiceManager\Factory\InvokableFactory;" & @CRLF & _
"" & @CRLF & _
"return [" & @CRLF & _
" " & @CRLF & _
" 'view_manager' => [" & @CRLF & _
" 'template_path_stack' => [" & @CRLF & _
" " & @CRLF & _
" __DIR__ . '/../view'," & @CRLF & _
" __DIR__ . '/../view/Application/_shared'" & @CRLF & _
"" & @CRLF & _
" ]," & @CRLF & _
" ]," & @CRLF & _
" 'controllers' => [" & @CRLF & _
" 'factories' => [" & @CRLF & _
" dsdsa" & @CRLF & _
" ]" & @CRLF & _
" ]," & @CRLF & _
" " & @CRLF & _
" 'service_manager' => [" & @CRLF & _
" 'factories' => [" & @CRLF & _
" " & @CRLF & _
" 'UsersTableGateway' => function ($sm) {" & @CRLF & _
" $dbAdapter = $sm->get('Laminas\Db\Adapter\Adapter');" & @CRLF & _
" $resultSetPrototype = new \Laminas\Db\ResultSet\ResultSet();" & @CRLF & _
" //get base url from config" & @CRLF & _
" $config = $sm->get('Config');" & @CRLF & _
" $baseUrl = $config['view_manager']['base_url'];" & @CRLF & _
" " & @CRLF & _
" //pass base url via cnstructor to the User class" & @CRLF & _
" $resultSetPrototype->setArrayObjectPrototype(new Model\Rowset\User($baseUrl));" & @CRLF & _
" return new Utils\TableGateway('users', $dbAdapter, null, $resultSetPrototype);" & @CRLF & _
" }," & @CRLF & _
" 'Application\Model\UsersTable' => function($sm) {" & @CRLF & _
" $tableGateway = $sm->get('UsersTableGateway');" & @CRLF & _
" $table = new Model\UsersTable($tableGateway);" & @CRLF & _
" " & @CRLF & _
" return $table;" & @CRLF & _
" }," & @CRLF & _
" Utils\Authentication::class => function($sm) {" & @CRLF & _
" $auth = new Utils\Authentication(" & @CRLF & _
" $sm->get(\Laminas\Db\Adapter\Adapter::class)," & @CRLF & _
" $sm->get(Utils\Adapter::class) " & @CRLF & _
" );" & @CRLF & _
" return $auth;" & @CRLF & _
" }," & @CRLF & _
" Utils\Helper::class => InvokableFactory::class," & @CRLF & _
" " & @CRLF & _
" SessionManager::class => function ($container) {" & @CRLF & _
" $config = $container->get('config');" & @CRLF & _
" $session = $config['session'];" & @CRLF & _
" $sessionConfig = new $session['config']['class']();" & @CRLF & _
" $sessionConfig->setOptions($session['config']['options']);" & @CRLF & _
" $sessionManager = new Session\SessionManager(" & @CRLF & _
" $sessionConfig," & @CRLF & _
" new $session['storage']()," & @CRLF & _
" null" & @CRLF & _
" );" & @CRLF & _
" \Laminas\Session\Container::setDefaultManager($sessionManager);" & @CRLF & _
" " & @CRLF & _
" return $sessionManager;" & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
" ]," & @CRLF & _
" ]," & @CRLF & _
"];"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")