#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<=<\/)|(?<=<))[^ >]+"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"" & @CRLF & _
"<html lang="en" xmlns="http://www.w3.org/1999/xhtml">" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="utf-8" />" & @CRLF & _
" <title></title>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
" <a></a>" & @CRLF & _
"</body>" & @CRLF & _
"</html> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")