re = /(?:[^|\n]+\|?){1,3}/
str = '723|NM|1|7201|QQ|1|72034|PP|1|72034N|AA|1|7203466|QW|1|72000|NM|1|7201111|NM|1
723|NM|1|7201|QQ|1|72034|PP|1|72034N|AA|1|7203466|QW|1|72000|NM|1|7201111|NM|1|123|NM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end