package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\s\d+(\s\d+)+`)
var str = `12 2 12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}