$re = '/^(\d{1,2}|100)$/m';
$str = '5652
10
40
99
955
55
100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);