const regex = new RegExp('(?m) (?<!^)(?=\\d+\\.)', 'g')
const str = `Giovinni Enrico
I GIO MORET FMJ
1.Air Jordan 2.Nike 3.Prada
4.Dolce & Gabbana 5.2.2.Diesel
Adriana Cazetto
ADRE CX GF 1.Air Jordan
2.Adidas 3.LV
4.2.8. Gucci`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);