$re = '/(\d+)/m';
$str = ' CMM_Nr = PRO-T 123456 ;% !Installation';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);