package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\A[\p{L}\s]+\Z`)
var str = `test Test TEST`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}