using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S{1,20}(?:\s+\S{1,20})){0,20}(?:\s+\1){6}";
string input = @":''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE:''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE :''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE :''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE :''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE :''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE :''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE :''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE :''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE :''Este artículo es sobre la criatura mítica. Para otros usos de este término, véase [[Vampiro (desambiguación)]]. Un '''vampiro''' es, según el [[folclore]] de varios países, una criatura que se alimenta de la esencia vital de otros seres vivos (usualmente bajo la forma de [[sangre]]) para así mantenerse activo. En algunas culturas orientales y [[América|america]]nas aborígenes, esta [[superstición]] es una [[Demonio|deidad demoníaca]] o un dios menor que forma parte del [[Panteón (mitología)|panteón]] siniestro en sus [[mitología]]s. En la cultura europea y occidental, así como en la cultura global contemporánea, el prototipo de vampiro más popular es el de origen [[pueblos eslavos|eslavo]], es decir, el de un ser humano convertido después de morir en un [[no muerto|cadáver activo]] o retornado [[Depredación|depredador]] [[hematófago|chupador de sangre]].<ref name=ref_duplicada_1>""Calmet Poupart, Augustin. ''Dissertations sur les apparitions des anges, des démons & des esprits et sur les revenans et vampires de Hongrie, de Boheme, de Moravie & de Silesie''. Publicado por De Bure l'aîné, 1746. [http://books.google.com.co/books?id=AoMAAAAAMAAJ]</ref> [[Archivo:Vernünftige und Christliche Gedancken über die Vampirs - 001.jpg|miniatura|Portada de un libro alemán de 1733 sobre vampiros.]] EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}