package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)h(?i)hello`)
var str = `Hhello hHello hHELLO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}