re = /extension .+\n./
str = 'import UIKit
extension UIColor {
func temp() {
}
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end