#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{13}\\n"
Local $sString = "" & @CRLF & _
"5038614652\n" & @CRLF & _
"9202032561428\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^[0-9]{13}" & @CRLF & _
"^[0-9]{10,}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")