$re = '/(?:(?<=[\s])(except (?:.|\s)*)(?=except))?|(?:(?<=\n)(except (?:.|\s)*)(?=$|\)))/m';
$str = 'where (
param1 equals value1
and
param 2 equals valu2
except (
param3 equals value3
where (
param4 equals value4
except (
param6 equals value6
)
)
)
)
except (
param5 equal value5
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);