$re = '/[\W\D](ft-file)[\W\D]/m';
$str = 'data/ft-file/images/small/red"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);