re = /(?:(?:[^\s<]*<\w[^>]*>[\s\S]*?<\/\w[^>]*>)+[^\s<]*)/m
str = 'i want to match<b>this</b>
and
<b>this</b>as one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end