re = /(?:VERSION|version|Version)[^0-9]*([0-9]+\.[0-9,A-Z,a-z]+\.[0-9,a-z,A-Z]+)/m
str = 'VERSION = "2.1.0"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end