$re = '/Jack.((?!Highlights).)*1080p/mi';
$str = 'Movie - Jack v John - 1080p
Movie - Jack v John - Highlights - 1080p
Movie - John v Jack - 1080p
Movie - John v Jack - Highlights - 1080p
I\'m hoping to match line 1 and 3.
An example I\'ve found that does most of this but doesn\'t exclude Highlights is:
Jack.*1080p
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);