# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*((youtu.be\/)|(v\/)|(\/u\/\w\/)|(embed\/)|(watch\?))\??v?=?([^#&?]*).*"
test_str = ("https://youtu.be/embed/n-WuWyZPcoE\n"
"https://youtube.com/embed/n-WuWyZPcoE\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o\n"
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
"http://www.youtube.com/embed/0zM3nApSvMg?rel=0\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg\n"
"http://youtu.be/0zM3nApSvMg\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.