using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G- ";
string substitution = @"-";
string input = @"- - - Three dashes a-b-c-d";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}