package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{[^{}]*\}`)
var str = `{{{{{{{{{{{{{{{{{{value1 here!}}}}}}}}}}}{value2 here!}}}}}}}}}{value3 here!}}}}}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}