$re = '/.*(Desktop|Downloads)\\\\(?<EXE_RAN>.*\.exe)/m';
$str = 'C:\\users\\user1\\Downloads\\blah.exe
C:\\Users\\user234\\Downloads\\sqldeveloper-17.4.0.355.2349-x64\\sqldeveloper\\sqldeveloper\\bin\\sqldeveloper64W.exe
C:\\Users\\user9823\\AppData\\Local\\iManage\\Installer\\Updates\\iManage Work Desktop for Windows x86.exe
C:\\Users\\johnsmith\\Desktop\\dataloader-44.0.0.exe
C:\\something\\else\\some.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);