$re = '/[<\[" ]?([^<>\[\]" =\x0a\x0d]+)[>\[" ]?/';
$str = 'foo[bar="baz"]
<element1>[<element2>="<element3>"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);