package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:mr|mrs|ms|miss|messrs|mmes|dr|prof|rev|sr|jr|&|and)\.?\b`)
var str = `one and two and three&four`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}