$re = '/\d{4}/m';
$str = 'Hello 0123 example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);