re = /\[(.*)\]/
str = 'Hoje fomos até São Paulo visitar o paciente, [236,AD-BF] e não foi possível chegar a um diagnóstico'
# Print the match result
str.match(re) do |match|
puts match.to_s
end