import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z_A-Z]+(?=\\=)|(?<=\\=)\\w+(?# =后面的变量或者数字)|(?<=\\=)\\'.+\\'|(?<=\\=)\\\".+\\\"(?# =后面的字符串)";
final String string = "a=1123 b=abcABC_ANV c='abc_ABC ABC123' d=\"abc_ABC ABC123\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}