re = /(i?)Liferay-Portal:.*?(\d+\.?.*?)\s/m
str = 'HTTP/1.1 200 OK
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Cache-Control: private, no-cache, no-store, must-revalidate
Pragma: no-cache
X-Frame-Options: SAMEORIGIN
Date: Mon, 24 Oct 2022 16:46:09 GMT
Connection: keep-alive
X-Content-Type-Options: nosniff
Transfer-Encoding: chunked
Content-Type: text/html;charset=UTF-8
Liferay-Portal: Liferay Community Edition Portal 7.4.3.15 CE GA15 (Cavanaugh / Build 7403 / March 11, 2022)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end