$re = '~([A-Za-z]+)_(\w+)~m';
$str = 'Bob_has_a_nice_house';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;