import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{2}:(([1-9][0-9])|(0[1-9]))";
final String string = "'00:00', '00:05', '00:15', '00:20', '00:25', '00:30', '00:35',\n"
+ " '00:40', '00:45', '00:50', '00:55', '01:00', '01:05', '01:10',\n"
+ " '01:15', '01:20', '01:40', '01:45', '01:55', '02:05', '02:10',\n"
+ " '02:15', '02:35', '02:40', '02:45', '02:55', '03:05', '03:10',\n"
+ " '03:30', '03:55', '04:00', '04:05', '04:25', '04:40', '04:55',\n"
+ " '05:00', '05:05', '05:15', '05:20', '05:25', '05:30', '05:35',\n"
+ " '05:50', '05:55', '06:05', '06:20', '06:25', '06:30', '06:35',\n"
+ " '06:45', '06:50', '07:05', '07:15', '07:30', '07:40', '07:45',\n"
+ " '07:50', '07:55', '08:10', '08:20', '08:25', '08:40', '08:45',\n"
+ " '08:50', '09:15', '09:20', '09:45', '09:50', '09:55', '10:10',\n"
+ " '10:15', '10:25', '10:30', '10:45', '10:50', '11:00', '11:05',\n"
+ " '11:15', '11:25', '11:35', '11:45', '11:50', '11:55', '12:00',\n"
+ " '12:10', '12:15', '12:25', '12:50', '12:55', '13:00', '13:40',\n"
+ " '13:45', '13:50', '14:00', '14:10', '14:20', '14:35', '14:55',\n"
+ " '15:05', '15:10', '15:15', '15:20', '15:25', '15:45', '15:55',\n"
+ " '16:10', '16:15', '16:20', '16:25', '16:35', '16:45', '16:50',\n"
+ " '16:55', '17:05', '17:30', '17:35', '17:45', '17:50', '18:00',\n"
+ " '18:05', '18:10', '18:15', '18:20', '18:30', '18:35', '18:45',\n"
+ " '19:00', '19:10', '19:20', '19:40', '19:50', '20:00', '20:15',\n"
+ " '20:20', '20:35', '20:45', '20:55', '21:00', '21:05', '21:15',\n"
+ " '21:20', '21:25', '21:30', '21:40', '21:45', '22:00', '22:10',\n"
+ " '22:15', '22:25', '22:40', '22:45', '22:50', '22:55'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}