package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Message: Help\. Reason: (?<firstpart>.*)\n\n.*?@ 1 @ (?<secondpart>.*).$`)
var str = `@ Timestamp @ ProcessInformation.Process @ <Null> @ Message: Help. Reason: This is going to be cut out at the 256th c
@ Timestamp @ ProcessInformation.Process @ 1 @ haracter.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}