using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W+(?!\S)";
string substitution = @"";
string input = @"a.. x what! he was a in the U.S.A.F but.!.! in the accounts dept?
This is a test. This is a test! This is a.b.c
!!!
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}