$re = '/\b(?:\d{6} \d{5}|[1-9]\d{4} \d{5}|[1-9]\d{9}|\d{11})\b/m';
$str = 'Pattern 1 - The length of this pattern is exactly 10 and cannot start with a zero. These consist of only integers. Ex: \'1234567890\'
Pattern 2 - The length of this pattern is exactly 11 and can start with a zero. These consist of only integers. Ex: \'01234567890\'
Pattern 3 - The length of this pattern is exactly 11 and cannot start with a zero. There is one space after the 5th number and all other characters are numbers. Ex: \'12345 67890\'
Pattern 4 - The length of this pattern is exactly 12 and can start with a zero. There is one space after the 6th number and all other characters are numbers. Ex: \'012345 67890\'
Note - The example pattern example provided is for representation only. The actual set of numbers in my string can be anything. Example: \'2345653340\' or \'034945 85730\' or \'000000 00000\' or \'09876543210\'.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);