re = /\b(?:\d{6} \d{5}|[1-9]\d{4} \d{5}|[1-9]\d{9}|\d{11})\b/m
str = '40658328721
07204432092
12345 67890
098373 67390
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end