re = /"[^"]+"(*SKIP)(*FAIL)|[-\[\][{}().,;+*\/&|<>=~]/
str = 'x += "hello + world"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end