$re = '/\[(.*?)\]/m';
$str = '[this should match]
[this should]
[this will not
]this wil not[
[yep]
[no]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);