package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\W_]+[^\s,]*)`)
var str = `This is working. Testing, one two three...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}