use strict;
my $str = 'class myClassA(myBaseClass) {
docstring = // End-of-line-comments possible
"
This is my class description docstring stored in a string variable inherited from
myBaseClass.
The content of this string, INCLUDING INDENTATION, MUST NOT be changed.
";
docstring = (
"
Enclosed in parentheses
"
);
// This variable is declared as string has a mismatched indentation:
string some_detailed_notes = "Some string like this is also possible.
Also with
some really
strange indentation
and `inline code`, ```code blocks``` $\\\\text{LaTeX}$ $$\\\\frac{1}{2}$$
:::{hint}
some admonitions
:::
and all kind of special characters such as:
\\"
(...)
{...}
[...]
;.,
etc.
which MUST be preserved.";
string some_other_string = "
do NOT touch this, only docstring and some_detailed_notes
";
}';
my $regex = qr/(?<=\s)((?:docstring|some_detailed_notes)\s*=\s*\(?\s*(?://.*\n\s*)*)"((?:[^"\\]|\\.)+)"(\s*\)?\s*;)/mp;
my $subst = '\\1R""""\\2""""\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";