// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^|]*\|){4}\s*").unwrap();
let string = "172.21.201.135 | http | o@1I0BTOx1063x3667295x0 | hkv | 2020-06-10 17:43:18,951 | \"POST /rest/build-status/latest/commits/stats HTTP/1.1\" | \"http://bitbucket.klp.no/projects/WF/repos/klp-libs/compare/commits\" \"Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36\" | 200 | 345 | 431 | - | 5 | 3dk4qm | ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}