$re = '/,(?![^(]*\))/m';
$str = 'ab, cd(c1,c2,d1), ef, gh ,ij(i1,i2,j1,j2)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);