import Foundation
let pattern = #"^(CREATE TABLE[^;]*;)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DROP TABLE IF EXISTS `admin_analytics_usage_version_log`;
/*!40101 SET @saved_cs_client = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `admin_analytics_usage_version_log` (
`id` int(10) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Log ID',
`last_viewed_in_version` varchar(50) NOT NULL COMMENT 'Viewer last viewed on product version',
PRIMARY KEY (`id`),
UNIQUE KEY `ADMIN_ANALYTICS_USAGE_VERSION_LOG_LAST_VIEWED_IN_VERSION` (`last_viewed_in_version`)
) ENGINE=InnoDB AUTO_INCREMENT=6 DEFAULT CHARSET=utf8 COMMENT='Admin Notification Viewer Log Table';
but not CREATE TABLE `admin_analytics_usage_version_log` (
`id` int(10) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Log ID',
`last_viewed_in_version` varchar(50) NOT NULL COMMENT 'Viewer last viewed on product version',
PRIMARY KEY (`id`),
UNIQUE KEY `ADMIN_ANALYTICS_USAGE_VERSION_LOG_LAST_VIEWED_IN_VERSION` (`last_viewed_in_version`)
) ENGINE=InnoDB AUTO_INCREMENT=6 DEFAULT CHARSET=utf8 COMMENT='Admin Notification Viewer Log Table';
/*!40101 SET character_set_client = @saved_cs_client */;
--
-- Dumping data for table `admin_analytics_usage_version_log`
--
LOCK TABLES `admin_analytics_usage_version_log` WRITE;
/*!40000 ALTER TABLE `admin_analytics_usage_version_log` DISABLE KEYS */;
INSERT INTO `admin_analytics_usage_version_log` VALUES (5,'2.3.4-p2');
/*!40000 ALTER TABLE `admin_analytics_usage_version_log` ENABLE KEYS */;
UNLOCK TABLES;
CREATE TABLE `admin_analytics_usage_version_log` (
`id` int(10) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Log ID',
`last_viewed_in_version` varchar(50) NOT NULL COMMENT 'Viewer last viewed on product version',
PRIMARY KEY (`id`),
UNIQUE KEY `ADMIN_ANALYTICS_USAGE_VERSION_LOG_LAST_VIEWED_IN_VERSION` (`last_viewed_in_version`)
) ENGINE=InnoDB AUTO_INCREMENT=6 DEFAULT CHARSET=utf8 COMMENT='Admin Notification Viewer Log Table';
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)