$re = '/\b[a-zA-Z]\w*\b(?!\[\d*\])/m';
$str = 'var1
var2[0]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);