$re = '/^[^|]{1,}/m';
$str = 'оборудование|механизм|потребление|экономичность|77333445|8845522|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);