package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bhow\b`)
var str = `string1
how to find
it is a show
okay how to`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}