re = /(?x)\b(?:[0-9]+(?:[- ]*[0-9]+)?|one|two|three|four|five|six|seven|eight|nine|ten
|eleven|twelve|thirteen|fourteen|fifteen|sixteen|seventeen|eighteen|nineteen|twenty)
[+ ]*years?\b/m
str = 'one year, honey 2-5 year, dressed six, ten
I bought a phone years ago'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end