re = /^(\/dev\/[\S]+|.*zroot\S*?) on (\/[\S]*) (?=(?:type)[\s]+([\S]+)|\(([^,]*))/
str = 'vmzroot/ROOT/freebsd on / (zfs, local, nfsv4acls)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end