# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\|\s*(logo|image|screenshot|race_logo|track map)\s*=\s*)(File:|Image:)?([^\[\||<\n]*)((\|\s*\d{1,4}px(\?)?|\|\s*thumb))((\|\s*\d{1,4}px(\?)?|\|\s*thumb))?(?(?=\|[A-z]*\s*=)|(?(?=\|(\w*\W*)*)(\|[^\|\n]*)?)?)"
test_str = ("| image = [[File:Central Asia (orthographic projection).svg|200px|Map of Central Asia]]\n\n"
"|Image=|150px? \n\n"
"}}]] – [[Template:POTD/2012-06-09|{{POTD texttitle\n"
"|image=Jack-in-cube solid model, light background.gif\n"
"|thumb=Jack-in-cube solid model, light background frame.png\n"
"|size=180\n\n"
"|name = Reggae\n"
"| Image = File:Bob-Marley.jpg|thumb|231px|\n"
"| caption = Popular reggae artist [[Bob Marley]] in 1980\n\n"
"{{Infobox officeholder\n"
"|image = Karenskiy AF 1917.jpg|230px\n"
"|nationality = Russian\n\n"
"{{Infobox officeholder\n"
"|image = Karenskiy AF 1917.jpg|230px|thumb\n"
"|nationality = Russian\n\n"
"{{Infobox officeholder\n"
"|image = Karenskiy AF 1917.jpg|thumb\n"
"|nationality = Russian\n\n"
"{{Infobox officeholder\n"
"|image = Karenskiy AF 1917.jpg|230px|nationality = Russian\n\n"
"|country=IND\n"
"|image= National Highway 2 (India).png|300px|Road map of India with NH 19 highlighted in solid blue color\n"
"|type=NH\n\n"
"|image = File:April 14, 2012 Marquette, Kansas EF4 tornado.JPG|309px\n\n"
"{{Infobox football club |\n"
" clubname = Slovácko |\n"
" image = Image:1FC Slovacko.png|150px|Logo |\n"
" fullname = 1. FC Slovácko A.S. |\n\n"
"| image = <imagemap>\n"
"File:Primates - some families.jpg|300px")
subst = "$1$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.